Announcement

Collapse
No announcement yet.

Eh700 loosing antifreeze, but not overheating?-gctid821844

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest
    Guest replied
    Transmission coolers... never thought about those. The pencil zinc on this motor was finished in 5 mos, the other one was almost new?, I'll look into that. Thanks for the feed back.

    Leave a comment:


  • brad4550
    replied
    You should do a leak down test on the Manicoolers and cap...test equipment can be purchased at any auto parts / Harbor Frieght. Good luck Brad

    Leave a comment:


  • Guest
    Guest replied
    + 1
    ..........

    Leave a comment:


  • Jim_Gandee
    replied
    It will not go the other way from the tank back to the manicooler.
    I've got the coolant expansion tanks on my 175's and they go both ways. Pun intended!

    Don't forget, the correct cap rating is 7lbs. A higher cap rating could contribute to coolant leakage due to increased pressure.

    Leave a comment:


  • Sunbird
    replied
    I had similar issues and spoke with Earl about this. Be aware that you don't fill the manicooler all the way to the top. There is a low & high indicator in side when you look thru the hole with the cap removed. These Hino's did not come with surge tanks- when you add them they are only to retain coolant that comes out- It will not go the other way from the tank back to the manicooler. If you are still certain you are losing antifreeze the first place to check is the transmission cooler. They usually fail first.

    Good Luck

    Leave a comment:


  • SuperiorDiver
    replied
    Similar issue on my Cummins. Heat exchanger was leaking. Replaced both sides since I suspect the other was not far behind. While doing the diagnosis, I tested the coolant tank caps and found they were supposed to hold something like 12 PSI, but leaked at 3. Replaced them as well.

    Leave a comment:


  • Pcpete
    replied
    You probably have a leak within the manicooler between the bundle and raw water jacket. It could be as simple as the isolation O rings at each end or there may be a hole in the bundle. In either case it may be that you will need to pull the manicooler and set it up on a bench.

    I recommend getting in touch with Earl the Baylinerguru http://www.susanmohr.com/index.html

    It doesn't matter where you are, he will recommend the best course of action and where to have you parts serviced. If you are in salt water time is of the essence.

    Leave a comment:


  • Guest
    Guest started a topic Eh700 loosing antifreeze, but not overheating?-gctid821844

    Eh700 loosing antifreeze, but not overheating?-gctid821844

    Hey folks, I bought a 3870 in great shape, but port hino is loosing antifreeze out of the cap?. I've hooked up a catchment tank to it and pulled out 2 gal since the problem started. It pulls very little back in after cool down and never seems to want more antifreeze no matter what I loose. Any thoughts?
Working...
X