Announcement

Collapse
No announcement yet.

5.7L / Bravo 2 Shifting Problem-gctid818999

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gowdy
    replied
    Shifter not in the stern drive. I pulled both out as far as I could and watched them until I couldn't see them anymore. Shifts fine!

    Thanks all.

    Leave a comment:


  • builderdude
    replied
    No resistance, it probably didn't make its way into the jaws correctly. BTW, the Bravo doesn't like to be shifted without the engine running.

    Leave a comment:


  • gowdy
    replied
    Rainy, so I can't work on it today.

    Thanks for the replies.

    I disconnected the cable from the manifold mount and pulled/pushed on it. There's no resistance, so I'm pretty sure the "ball" on the end didn't secure in the jaws.

    I'll do this again with the motor running, but I'm about positive that there's nothing connected to it.

    Besides pulling it out as far as possible, what else can I do when I inspect it this weekend?

    I pushed in and pulled out the jaws to make sure they were working before I reassembled and watched the "ball" on the end of the cable go into the open jaws.

    Of course, I couldn't really tell anything when the drive was very close to the transom mount, but the cable was in the jaws.

    Leave a comment:


  • Ruffryder
    replied
    So the shift lever still moves FWD NEUTRAL REVIEW? Or lever stuck in FWD.

    As you said if you can push the control forward or back,

    Shift linkage wasn't pulled out enough, jaw wasn't fully open to close the lower shift cable end ball most likely.

    Leave a comment:


  • builderdude
    replied
    To verify you could disconnect the lower shift cable from the shift bracket on the manifold and pull the cable end forward/away from the drive, should be able to shift it to neutral and reverse if it's locked into the jaws properly.

    Leave a comment:


  • builderdude
    replied
    Sounds like your lower shift cable didn't actually make its way into the "jaws" of the drive like it needed to. This would cause the drive to be stuck in forward gear.

    Leave a comment:


  • gowdy
    started a topic 5.7L / Bravo 2 Shifting Problem-gctid818999

    5.7L / Bravo 2 Shifting Problem-gctid818999

    I removed and replaced my engine due to a sheared starter bolt. Everything went smooth.

    I watched the shift cable go into the stern drive as it should and the control was in neutral the whole time.

    I tried to take a ride today and only have forward gear.

    Whether I push the control forward or back, I get increase in engine RPM and it stays in forward gear. There is no neutral.

    The "settings" on the cables were not altered (until this afternoon :whistle: ) and the nuts are not over tightened.

    Thanks for any suggestions.
Working...
X