Announcement

Collapse
No announcement yet.

TEMP GETTING HOT-gctid816041

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bucluv
    replied
    Just changed the T ball valve assembly on top of the thermostat housing and my Riser is still getting hot I even switched the thermostat housing with the T ball valve assembly to the other engine and now that engine is getting hot so I know it has to do something with that Tebow valve assembly and thermostat housing

    Leave a comment:


  • bucluv
    replied
    Found out it was the spring loaded hose connection on top of the thermostat housing that was getting stuck. The Springs we're getting stuck and not allowing sufficient water to flow. Hopefully I can just change out that piece and not buy a new thermostat housing .....any suggestions thanks

    Leave a comment:


  • bucluv
    replied
    Thanks guys I run in saltwater and I just changed both Impalas beginning of season also my starboard engine is not connected to the water heater. I figured something is restricting the flow when I am at high RPMs and it is not getting sufficient water I guess I need to start checking everything

    Leave a comment:


  • yachtman
    replied
    I don't know about your engine history if it didn't run higher before. However on my inboard engine manual it states

    The starboard engine which is connected to a water heater will typically run 10-15 degrees warmer than the port engine ,and mine does.

    I dont know if that is the configuration you have but if you do it could be an answer to the difference.

    Beyond that check strainers hoses antifreeze loss from exchanger and water pumps.

    Leave a comment:


  • itsabowtime2
    replied
    Do you boat in salt water? If so and are not running a "closed cooling system" you could have a blockage.

    When is the last time the impellers were changed?

    Have you run in shallow water recently? If so you could have ingested some sediment.

    Leave a comment:


  • Chief_Alen
    replied
    Bravotities

    Leave a comment:


  • bucluv
    started a topic TEMP GETTING HOT-gctid816041

    TEMP GETTING HOT-gctid816041

    Hey everybody. I have a 2005 305 with 5.7 l engines and Bravo Two drives. My starboard engine starts to run a little hot when I'm at cruising speed around 3200 RPMs the temp goes up. I would say 10 or 15 degrees When I'm at idle or low RPMs around 2000 the temp stays where it should be. Any opinions thanks in advance
Working...
X