Announcement

Collapse
No announcement yet.

Honda EU65IS Generator-gctid814054

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Honda EU65IS Generator-gctid814054

    My Honda generator is starting with no problems but when we put load on it a large amount of white smoke starts to come out of the exhaust. It is not a blown gasket as there is no sign of any problems in this area. Can anyone offer me an easy fix.

    #2
    If it has high hours its probably burning oil. I have had 3 Honda generators do this to me. Usually the EU series are good for around 500 to 700 hours and then thats about it. I know that I will be thoroughly scolded for my next statement but I will no longer purchase Honda products due to poor durability.
    1988 Mainship 36 Sedan
    1995 2858
    1988 2655
    1987 2150
    Commercial/Industrial HVAC Service Tech.

    Comment


      #3
      Try changing the oil and see if it clears up. Also do NOT attempt to use synthetic oil as it will foam up.
      1988 Mainship 36 Sedan
      1995 2858
      1988 2655
      1987 2150
      Commercial/Industrial HVAC Service Tech.

      Comment


        #4
        Its done less than 50 hours but has been not been started for some time. I will change the oil & let you know the result. Thanks for your input.

        Comment


          #5
          "RPrather" post=814056 wrote:
          Try changing the oil and see if it clears up. Also do NOT attempt to use synthetic oil as it will foam up.
          No offense meant but I call bologna. Ive used nothing but synthetic in my Honda. I would use nothing other in fact. Been running my EU2000 for close to 10 years now without an issue.
          "REEL WILD"
          2001 2859 FNM 300 Diesel-Bravo 2
          Anchorage, Alaska
          If you don't like the weather, wait 15 minutes.......

          Comment


            #6
            "aknurse" post=814076 wrote:
            "RPrather" post=814056 wrote:
            Try changing the oil and see if it clears up. Also do NOT attempt to use synthetic oil as it will foam up.
            No offense meant but I call bologna. Ive used nothing but synthetic in my Honda. I would use nothing other in fact. Been running my EU2000 for close to 10 years now without an issue.
            +1.
            1999 3788, Cummins 270 "Freedom"
            2013 Boston Whaler 130 SS
            Anacortes, WA

            Comment


              #7
              +2 eu 3000
              Gibraltar, Mi.
              1986- 3870- Hino 175's
              1988 26' Shamrock/ Diesel
              14' Zodiac Bay Runner

              Comment


                #8
                We changed the oil & cleaned the fuel system but still white smoke when under load. It stalls after a few seconds of the white smoke starting. What can it be.

                Comment


                  #9
                  I think it is burning oil. The cylinder walls and piston rings on engines that have not been started in a can corrode.
                  1999 3788, Cummins 270 "Freedom"
                  2013 Boston Whaler 130 SS
                  Anacortes, WA

                  Comment


                    #10
                    We did some more cleaning & added plenty of Carburetor cleaner & its looks like the problem is solved We will run her all Saturday night which will be a good test.

                    Comment


                      #11
                      How long was the gas in there? Was it ethanol?

                      Never mind the oil; change the gas.....
                      Captharv 2001 2452
                      "When the draft of your boat exceeds the depth of water, you are aground"

                      Comment


                        #12
                        I'm glad to hear that the problem was solved.

                        To avoid it in the future try to use non-ethanol gas and add Stabil to it. Also, start and run the generator for 15 minutes monthly. Try to put a load on it when you do this. I use space heaters for the load.
                        1999 3788, Cummins 270 "Freedom"
                        2013 Boston Whaler 130 SS
                        Anacortes, WA

                        Comment


                          #13
                          We had her running fine but when we switched on the air con it would stutter & stall. We found an O ring that was perforated on the fuel off/on valve so changed it & she is running better than ever.

                          Comment

                          Working...
                          X