Announcement

Collapse
No announcement yet.

2004 Trophy Pro 2359 speedometer issue-gctid813081

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    2004 Trophy Pro 2359 speedometer issue-gctid813081

    Bought this boat used, low hours, excellent condition, but speedometer does not work. Now there is more to this than meets the eye.

    This craft has the Mercruiser SmartCraft(?) technology for the engine/outdrive. Partly because FloScan was so expensive for so little, and the fact that the "MercMonitor" gives me all of what FloScan does with the addition of onboard system info. So bought it and hooked that all up (Original speedo has never worked). I am getting a fault on the MercMonitor for speedometer. I was getting one for trim also, but found a digital and the analog connections and swapped them. Lost the dial on the dash but gained the info in the MercMonitor for trim.

    So far, I am unable to figure out the speedo issue. I do know the tube from the pickup is intact from the pitot to the transom and where it comes into the speedo area it is connected, seems to just be air tube.

    So is there a digital connection somewhere for the speedo? The fuel economy wants the speed information. Pretty neat system, looking forward to having it all work.

    #2
    check for ubstruction at the leading edge of the lower unit. That's where the air tube recieves the pressure for the OEM gauge but doesn't the Mercmonitor want GPS speed?
    Dave
    Edmonds, WA
    "THE FIX"
    '93 2556
    Carbureted 383 Vortec-Bravo II 2.0:1 18 1/4x19 P

    The rebuild of my 2556 https://www.baylinerownersclub.org/f...76?view=thread
    Misc. projects thread
    https://www.baylinerownersclub.org/f...56-gctid789773

    Comment


      #3
      One of the screens has space for that but no GPS hooked in, got version without GPS or NMEA, that is on SmartTow.

      Is there a relay for the speedo somewhere within the engine compartment?

      Comment


        #4
        One other point that may be important. The boat sat in an large garage without climate control for 5 years untouched.

        Comment


          #5
          The OEM speedometer gauge works on air pressure. The pressure is created by the water flow past the lower unit being forced into the hole at its leading edge. These OEM speedometers are not very accurate and frequently give bizarre readings or quit working completely because of debris or marine growth around or in the hole at the lower unit and the tube itself can become damaged as well.
          Dave
          Edmonds, WA
          "THE FIX"
          '93 2556
          Carbureted 383 Vortec-Bravo II 2.0:1 18 1/4x19 P

          The rebuild of my 2556 https://www.baylinerownersclub.org/f...76?view=thread
          Misc. projects thread
          https://www.baylinerownersclub.org/f...56-gctid789773

          Comment


            #6
            Okey dokey, will pull her out of the water tomorrow and check. I don't see how the MercMonitor gets any speed data in that case. Time to contact them I guess. Not sure how it effects the "ECO" trim screen to not have speed info. I get it off my plotter and VHF, just no way to interconnect them.

            Comment


              #7
              3 options to get the Smartcraft speedo show speed

              1. pitot sensor

              2. Smartcraft GPS Antenna

              3. NMEA0183 GPS Antenna via the blue and white cable in the instrument harness

              Go into the gauge settings and see if it is set at paddle or pitot ...

              If so as inaccurate as they are, I would get a NMEA0183 GPS Antenna or if you have a NMEA 2000 plotter, that would work also.
              Joon, Kathy, Jaden & Tristan
              Uniflite 42 AC, DD 671N
              93 3058 sold
              92 2855 (day boat)
              91 Fourwinns 205 (lake boat)
              Longbranch WA
              Life is Good

              Comment


                #8
                Where might I find the pitot sensor? On motor or in instrument cluster? That is flashing error message.

                You are very knowledgable, you work on these?

                Thanks again

                Comment


                  #9
                  Smart craft Pitot sensor would need to be purchased. Personally I'd think GPS speed data communicating to the smart craft would be a better choice.
                  Dave
                  Edmonds, WA
                  "THE FIX"
                  '93 2556
                  Carbureted 383 Vortec-Bravo II 2.0:1 18 1/4x19 P

                  The rebuild of my 2556 https://www.baylinerownersclub.org/f...76?view=thread
                  Misc. projects thread
                  https://www.baylinerownersclub.org/f...56-gctid789773

                  Comment


                    #10
                    "builderdude" post=813237 wrote:
                    Smart craft http://www.marineengine.com/newparts...> Pitot sensor would need to be purchased. Personally I'd think GPS speed data communicating to the smart craft would be a better choice.
                    You kinda need both. The pitot tube gives you speed relative to the water. GPS gives you speed over ground: basically boat speed + current. The pitot tube is necessary for figuring out optimal cruise speed through water. GPS is necessary for figuring out optimal cruise speed for a particular trip (it's more fuel efficient to slow down relative to the water when you're going with the current, speed up when you're going against the current, although wave conditions may make that impossible).
                    1994 2556, 350 MAG MPI Horizon, Bravo 2

                    Comment


                      #11
                      So, where in the harness would the hookup for this be,any idea? Will it be labeled like the trim wires were? Need to make sure mine has the connection before I go order stuff.

                      Comment


                        #12
                        Yes I do.

                        You only need one source...

                        SC will only let you select one setting.

                        See if you can see the pitot tube is still connected above the anti cavitation plate,

                        If so the pitot pick-up tube for the speedo begins with a small hole on the front of the lower gear case. check this hole and make sure it is clear.
                        Joon, Kathy, Jaden & Tristan
                        Uniflite 42 AC, DD 671N
                        93 3058 sold
                        92 2855 (day boat)
                        91 Fourwinns 205 (lake boat)
                        Longbranch WA
                        Life is Good

                        Comment


                          #13
                          Yep pulled her out yesterday, cleaned a minor amount of guck out, tube appeared intact. Put her back in and the analog still not work and still get pitot error message. Any idea where to look for the connector for the pitot sensor location on a 5.0 MPI (2004) so I can see if the harness has the connection. If so I will purchase the sensor.

                          Edit: I have plugs labeled "Transom Harness", "Paddlewheel SeaTemp", and "Transmission Overtemp".

                          Comment

                          Working...
                          X