Announcement

Collapse
No announcement yet.

1996 Capri 1950 no spark from coil-gctid811081

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    1996 Capri 1950 no spark from coil-gctid811081

    I've got no spark coming from ignition coil. I've replaced the coil and coil wire...still no spark. I checked fuses behind dash...all are good. Don't know where else to check. Boat turns over good, it's getting fuel.... it has the 3.0 mercruiser with the digital electronic ignition. Any help??? Stuck at the lake with a non running boat. Ran great last year.

    #2
    My guess would be with ignition control module. Its mounted in the distributor on my 1998 1950. 2 small bolts hold it in. In my time working at a GM dealer I replaced god only know how many of these. i personally carry a spare. They usually give no warning, just go poof

    Comment


      #3
      Cycle the kill switch a few times before you do anything else.

      Post back !
      Be good, be happy, for tomorrow is promised to no man !

      1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

      '86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

      Manalapan N.J

      Comment


        #4
        So, I disconnected the shift interlock plug from distributor and it fired up. Repair manual says to replace magnetic shaft assembly ... which would be distributor. Can it be run without the shift interlock plug plugged in? I'm thinking about trying the module before pulling distributor.

        Comment

        Working...
        X