Announcement

Collapse
No announcement yet.

3.0 heavy misfire under load-gctid809013

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    3.0 heavy misfire under load-gctid809013

    I have a 1987 trophy hardtop with 3.0 omc I/o. The boat starts and runs awesome but at 2500rpms it's like I hit a wall and it just severely misfires. The problem kind of slowly came on and got worse. Right before the problem got really bad I changed the oil and did bellows/gimbal bearing. After the problem got this bad I've tried points, setting point gap, checked timing, plugs look good, put dry gas and sea foam in tank and made sure it was dumping plenty of fuel. And ideas? Thanks in advance

    #2
    Did you try running her with the fuel cap open?
    Joon, Kathy, Jaden & Tristan
    Uniflite 42 AC, DD 671N
    93 3058 sold
    92 2855 (day boat)
    91 Fourwinns 205 (lake boat)
    Longbranch WA
    Life is Good

    Comment


      #3
      I would be suspicious of some kind of ignition breakdown. You checked the points but did you replace the cap and rotor ? and you could test the spark plug wires with an ohmmeter but I would recommend replacement if there more than a few years old. And even if the plugs look good they can still be faulty. It pays to do a full tune up before you try to diagnose any other part of the engine system, you will come out ahead in the long run unless you value your time at $0.
      1990 3888 Bayliner, Twin 351's

      Comment


        #4
        Omc correct ?

        While some one is operating the boat, disconnect the esa module while you are accelerating if you get to around 4200 - 4600 wot you found your problem.

        See if that fixes the problem.

        Be aware you won't be able to shift out of gear.
        Be good, be happy, for tomorrow is promised to no man !

        1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

        '86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

        Manalapan N.J

        Comment


          #5
          A compression test should be in order also. My 3.0 idled nice and pulled pretty well until 2500 then went flat and did nothing but stumble. I had a bad valve on #3, valve job and we were gold again. You can borrow the tester from Orielly Auto parts or buy a cheap one form Harbor Freight like I did.

          Mike
          2004 Bayliner 285 350 MPI Bravo III
          2007 Bayliner 192 Discovery 3.0 135HP (sold)
          2000 Ciera 2455 sold
          Redmond, Washington
          The one on the Left (Wet) Coast

          Comment


            #6
            You have water in your gas....lots of water.
            Vic Stewart SN
            Past Commander
            Cape Fear Power Squadron
            Ft Myers Power Squadron
            1998 2859 7.4 L/B2
            Raw water cooled

            Comment


              #7
              After trying all suggestions today it turned out to be the coil! Thanks everyone for the input!

              Comment

              Working...
              X