Announcement

Collapse
No announcement yet.

1974 liberty bog down-gctid802695

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    1974 liberty bog down-gctid802695

    He guys ive been restoring a 1974 liberty hardtop, never seen my model in a hardtop and got what seemed like a smoking deal on it, after new floors,stringers adding some teak hatches and bulk head id say im now into to her for a lot more then shes worth but hell its been fun drinking beer in the driveway working away on her. ok so its been repowered looks like 99ish 3.0 mercuiser and aplha. ive had many issues with it after pulling and reinstalling the power and legs, the starter,cap,plugs,wires,coil,riser are all brand new along with bus heater, shore power and head added. End of last summer last year on a trip to the gulf island i lost spark so got the new cap and coil plugs and wires(marina installed), fired right up and headed home all seemed good, about 10mins from the dock i started losing oil pressure {slowly} got down to 8 pounds by time i got to the dock and pulled it. found a broken fitting to my oil pressure alarm fixed and added oil. Did a test run no problems for about 20mins oil pressure was at 30ish at idle 45ish at 3500 rpm, then bam some sort of crackel noise and bogs down , got back to the dock by just putting her in gear and doing 1 or 2 mph home, if i added any throttle over 1000 rpm it would bog down and stall, got it home starts runs fine and revs fine with out load.........ideas

    #2
    Oil milky overfilled ?

    Overheating ?
    Be good, be happy, for tomorrow is promised to no man !

    1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

    '86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

    Manalapan N.J

    Comment


      #3
      No over heating oil was clean low from the leak but topped up and at a good level guessing carb or filter but just spit balling

      Comment


        #4
        Compression on a warm engine, all the plugs out, throttle fully forward, using a good known screw in gauge.

        Post back after test, keep track of what plug came out of what hole.
        Be good, be happy, for tomorrow is promised to no man !

        1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

        '86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

        Manalapan N.J

        Comment


          #5
          test done 152 in #1 145 #2 150 #3 and 150 #4 plugs looked ok tho i will replace them anyway, seem 2 me these are pretty solid numbers.......more confused now lol

          Comment


            #6
            Those numbers look fine. You think it acted as if it were starving for fuel at a higher rpm loaded? have you checked the fuel tank vent line and fitting?You could try a test with the fuel fill cap removed. There's also the possability of a sticky anti siphon valve in the fuel delivery line (if equiped)
            Dave
            Edmonds, WA
            "THE FIX"
            '93 2556
            Carbureted 383 Vortec-Bravo II 2.0:1 18 1/4x19 P

            The rebuild of my 2556 https://www.baylinerownersclub.org/f...76?view=thread
            Misc. projects thread
            https://www.baylinerownersclub.org/f...56-gctid789773

            Comment


              #7
              it happens almost instantly under load only, put just into gear and she seems fine smallest increase and starts stumbling/bogging down revs up on the hose perfectly. ill check the filter and lines but its a twin tank with twin breathers so im guessing thats not it either. i checked the fuel filter end of last summer when i lost spark thinking it was a fuel problem, was clean but ill check again. pretty happy with the compression numbers but its a little ticky and knocks a bit doesnt sound great 2 me.......oil pressure seems low 2 idle is 25/28 area and under rev on the hose jumps to 40ish at 4000rpm or so

              Comment


                #8
                I think your oil pressure is ok. So this "newer engine" what ignition system is it running? from your initial post it sounds like the the ignition coil quit and after you had it replaced it only ran good for 10 minutes? I've read the coil is specific for TB ignition.
                Dave
                Edmonds, WA
                "THE FIX"
                '93 2556
                Carbureted 383 Vortec-Bravo II 2.0:1 18 1/4x19 P

                The rebuild of my 2556 https://www.baylinerownersclub.org/f...76?view=thread
                Misc. projects thread
                https://www.baylinerownersclub.org/f...56-gctid789773

                Comment


                  #9
                  In one of your posts you did rotor cap / points etc did you replace the condenser at the same time I don't even know if you have one just I had a car motor doing the same thing under load after new points / plugs / coil still doing it turned out to be the condenser just a thought.

                  Comment


                    #10
                    If the vent is clear, the filter in the fitting that enters the carb is clean, the screen on the pickup tube is clean, the anti syphon valve is clear / working correctly, all the bends in the fuel delivery is clear, depending on fuel pump that filter is clear and clean, and you have all new fuel hose, on a 99' engine you should, the power piston could be bad in the carb

                    I would have maybe said the lower shift cable is out of wack, but you posted it shifts fine then the slightest advance of the throttle the engine bogs down .

                    Give this a read ...

                    http://www.carburetor-parts.com/Merc...ng_ep_482.html

                    Question - this a tks ?
                    Be good, be happy, for tomorrow is promised to no man !

                    1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

                    '86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

                    Manalapan N.J

                    Comment


                      #11
                      Hook her up to a portable gas can carefully, see how she runs...
                      Joon, Kathy, Jaden & Tristan
                      Uniflite 42 AC, DD 671N
                      93 3058 sold
                      92 2855 (day boat)
                      91 Fourwinns 205 (lake boat)
                      Longbranch WA
                      Life is Good

                      Comment


                        #12
                        This is my set up if it helps at all


                        Attached files

                        Comment

                        Working...
                        X