Announcement

Collapse
No announcement yet.

New Boat And Motor Skip And loud Ticking-gctid383352

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New Boat And Motor Skip And loud Ticking-gctid383352

    I Bought A leftover 2011 Bayliner with a 2011 Mercury 115 EFI 4 Stroke .I have taken it out twice for a total of 4 hours run time. When I was taking boat out at the ramp I noticed a tick and skip at idle. Checked oil and flushed cooling system oil full tick and skip still present. I'm bringing it in for service this week at a local Mercury dealer. Anyone have this problem with a similar motor ? How well does Mercury treat customers with warranty repairs. Will I get my boat back in a reasonable amount of time ? New England boating season is short ! Thanks for any advise .

    #2
    I don't know about the tick and that particular motor.

    I do know that Mercury has been very good to me about warrantee items.

    How quickly it gets done? I think it depends on your dealer. I have been very fortunate to use Fox Lake Harbor, in IL. This spring while getting the boat ready for me to pick it up they found a problem. It was only a couple days and the parts were there and immediately installed.

    Good Luck,

    Comment


      #3
      I had motor checked and was told nothing was wrong and keep breaking it in. A few months later and just after my 100 hr service I went on vacation on Cape Cod .First day I was on a lake accelerated hard and heard a pop .Limped it back to the ramp pulled motor cover and saw a hole in the block # 4 cylinder failed . I went to Nausett marine in Orleans Ma They replaced power head under warranty .Vacation was spoiled without a boat .3 weeks later I got boat back and all has been well with the new power head 150 hours later .

      Comment

      Working...
      X