Announcement

Collapse
No announcement yet.

Force 85hp lower unit re-install after changing impeller-gctid376945

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Force 85hp lower unit re-install after changing impeller-gctid376945

    So I decided to change the impeller on my Force 85hp outboard and when I removed the lower unit a rubber tube and metal ring fell out.They look like this:

    [img]/media/kunena/attachments/vb/680390=27123-2012-04-30_22-12-16_718.jpg[/img]I think they go around the copper water tube that connects to the impeller. But I don't see them in my service manual.

    [img]/media/kunena/attachments/vb/680390=27124-2012-04-30_22-11-35_408.jpg[/img]And I think they go together like this:

    [img]/media/kunena/attachments/vb/680390=27125-2012-04-30_22-11-58_98.jpg[/img]Can anyone confirm if this is correct, I don't see these parts in my service manual. Also, what's the best method for re-installing the lower unit with these loose parts?I tried by myself and they keep falling back out.

    #2
    Additional information:

    With Mastertech's help I now know that it's the crankshaft spindle seal that sits on top of the drive shaft spindle splines. I found an image in my service manual that shows it, but I can't tell in what direction the bushing sits.

    1. It can either sit up with the seal going inside it.

    or

    2. It can sit down and it will rest over the ledge in the crankshaft.

    #1 seems to make more since but I can't tell for sure from the image in the service manual.

    Anyone else have a 1980-1988 85 or 125hp Force outboard?

    Comment


      #3
      The cup goes up and the thick part of seal goes toward top

      Comment

      Working...
      X