Announcement

Collapse
No announcement yet.

Removing Walker Airsep and replacing with SBMAR envirovent.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I've run both systems. The original Airsep on my boat worked fine. The only issue was the large, unsupported weight of the filter canister. It kept working its way off.

    I bought the factory recon engines from Sbmar, and they came with their system installed. I like the simpler, lighter weight system
    1999 3788, Cummins 270 "Freedom"
    2013 Boston Whaler 130 SS
    Anacortes, WA
    Isla Verde, PR

    Comment


      #17
      Well, the installation is complete.

      I found that on the engine that seemed to be leaking oil that the hose from the engine vent to the filter was full of oil.
      This tells me that the root cause for the "leak" was the check valve going to the oil pan.

      Here are some tips for installation...

      Have the largest youi could ever imagine. This will make getting the timing cover off and the sbmar adapter on Much easier.
      This project is possible without removing the aftercooler, but it would be MUCH easier to do concurrent with aftercooler servicing.

      OLther than that it's a really straight forward installation. Takes about an hour to an hour and a half per side, not counting time to move your remote oil filter if your boat has one.

      KEVIN SANDERS
      4788 LISAS WAY - SEWARD ALASKA
      www.transferswitch4less.com

      Whats the weather like on our boat
      https://www.weatherlink.com/embeddab...59665f4e4/wide


      Where are we right now? https://maps.findmespot.com/s/36S4

      Comment


        #18
        Ok, Kevin and the rest of you convinced me to try this. Today I had my aftercoolers removed for their tri-annual maintenance and chatted with the tech about installing the envirovent on the port engine. That’s the one that burps oil. Also, I had a new walker airsep installed on the starboard side a few years ago. He said he could easily do it even after reinstalling the aftercoolers. Ordered it today and scheduled to install in a couple of weeks.
        Evan
        2001 Bayliner 4788 "Fifty / Fifty II"
        League City, TX

        Comment


          #19
          Originally posted by egbauman View Post
          Ok, Kevin and the rest of you convinced me to try this. Today I had my aftercoolers removed for their tri-annual maintenance and chatted with the tech about installing the envirovent on the port engine. That’s the one that burps oil. Also, I had a new walker airsep installed on the starboard side a few years ago. He said he could easily do it even after reinstalling the aftercoolers. Ordered it today and scheduled to install in a couple of weeks.
          That sounds fantastic!!!

          While the aftercoolers are off to save labor time...

          Cap the vent port
          Cap off the line going to the oil pan.

          These two things are REAL buggers to get to with the aftercoolers on, but would be a breeze with them off.

          KEVIN SANDERS
          4788 LISAS WAY - SEWARD ALASKA
          www.transferswitch4less.com

          Whats the weather like on our boat
          https://www.weatherlink.com/embeddab...59665f4e4/wide


          Where are we right now? https://maps.findmespot.com/s/36S4

          Comment


            #20
            Evan, was the Airsep you replaced a few years ago, a direct replacement size wise, particularly the little air cleaner that fits behind the aftercooler? Well, prepare for a workaround repositioning that smaller filter on the new model as it ain’t gonna go where it sat previously. Take some pics and let us know how you go!

            Cheers
            John H
            Brisbane QLD Aust
            "Harbor-nating"

            2000 - 4788/Cummins 370's

            Comment


            • higgins_jr
              higgins_jr commented
              Editing a comment
              Sorry Evan, I misread your post. I thought you were going with a new Airsep. Welcome to the environment club 🤭. Cheers

            • higgins_jr
              higgins_jr commented
              Editing a comment
              Damn autocorrect! 😏😏. Envirovent

            #21
            Tony,
            sorry for the delay. Just happened to reread this thread. I have the envirovent connection on the valve cover. I remove the hose by heating it just a bit with heat gun. Comes right off. I also heat it a bit when putting it back on. It’s an extra step but only takes a few extra minutes.
            2000 4788 w Cummins 370's, underhulls, swim step hull extension
            12' Rendova center console with 40HP Yamaha
            MV Kia Orana
            Currently Enjoying the PNW

            Comment

            Working...
            X