Announcement

Collapse
No announcement yet.

Westerbeke genset-gctid804913

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Westerbeke genset-gctid804913

    Good Day,

    I have a 8kw Westerbeke on my 3988. My problem is getting raw water to the raw water pump. I have checked all hoses, cleaned the heat exchanger and of course made sure the sea strainer was functioning.I keep burning up impellers and am at a loss as to the problem. It has to be something small. Anyone else had this happen ?

    Regards, Sea Shift

    #2
    You could have something blocking the intake to the strainer. Use a shop vacuum in reverse and blow down onto the strainer with a rag sealing the top. Or.. the raw water pump may be worn to the extent it no longer creates suction. { check the shaft bearings and the cam.} or.... exhaust riser plugged up causing restricted flow. When you have a new impellor installed , how does the water flow seem out the exhaust? I assume the gen set is getting hot, does it auto-shutdown?

    Cheers, Gary
    Afterglow 4788
    Gary Weiss
    Sidney BC
    ArbutusCoastYachts.com

    Comment


      #3
      Hey Gary,

      Just the boat hauled, no problem with the strainer.Yes it does get hot and shuts down. The raw water pump seems to be in good condition and I can't see the exhaust elbow being blocked. I did attach a garden hose to the raw water side and ran it with no issues ,heat exchanger and exhaust riser stayed cool.Out of ideas.

      Simon.

      Comment


        #4
        "

        Hi Simon, Where do you boat?

        Has this been a on going problem our after you hauled?

        Just the boat hauled," Did you do bottom paint? Maybe they plugged the inlet with paint.

        The original gen intake through hulls have very small holes. They can plug very easily with flotsam, grass, or jellyfish. I opened mine up with a drill and it helped. I avoid running the gen in junky water or when the Jellies are breeding.

        You haven't said but I'm assuming you don't have any water flow out the exhaust with raw water but with the dock water connected you do. Correct?

        "Checked all hoses,"

        (Is your generator in a sound box?, If it's equipped with hose connector tubes through the base of the box check that they are not obstructed with corrosion.) I found mine was restricting flow.

        (You say it works with dock water connected, maybe the inside of the inlet hose is collapsing under suction but flows under dock water pressure.) Note: Don't leave water connected without the engine running or you may flood the cylinders.

        "Cleaned the heat exchanger"

        Did you pull both end caps and rod it?

        Chris

        Comment


          #5
          "It has to be something small. Anyone else had this happen ?"

          It maybe an air leak on the suction side of the system.

          Are you sure the strainer top is completely sealed? That all the fittings and hose connections do not leak air? And that the shaft that spins the impeller is completely sealed on the drive side?

          If it is an air leak you will typically (but not always) be able to get it primed and running by 'pushing' water from the hose that attaches to the impeller pump back through the system all the way out of the boat with a garden hose. After that pull the garden hose off and replace the connection quickly and start it up right away and check flow.

          If that works well but it will not prime later after sitting for a few hours you likely have one of the air leaks mentioned.

          Hope this helps
          Northport NY

          Comment


            #6
            I would bet Smitty has nailed it. Our previous boat had a small O'ring under the cover on the water pump, if it wasn't totally in the groove, the pump would suck air and not pump.

            You should carefully check/replace the gasket under the cover plate.

            Comment


              #7
              I have a bleeder hose t-eed in right after the pump. If I haven't used the ac in a while, I have to open the petcock on the bleeder to get the water flowing. I just let it pump into a small bucket and once I get a good flow, I close the petcock and all is fine. It must get air-locked.
              Greg A.
              1994 4788
              "Simplicity"
              2002 Capri 175
              "Little GFI"
              Boat on the Sac/San Joaquin Delta

              Comment


                #8
                Hey Fellas,

                All areas have been gone over, strainer flowing , pump sealed and turning, heat exchanger clean , hoses clear . Because it ran well with the garden hose attached , maybe the supply hose from the strainer is collapsing and restricting flow...?

                Simon.

                Comment


                  #9
                  Hi Simon

                  You could have a bad Seacock..or blockage in same, or blockage in hose Seacock to strainer.

                  Good luck Brad
                  Brad & Sharon
                  Lady Jake
                  1985 4550 EH 700TI /Twin Disc 502
                  LaConner,Wa. (summer)
                  2003 Scout CC 24' W/225 Yamaha
                  kailua Kona,Hi (Winter)

                  Comment


                    #10
                    I have had the inlet plugged with sea grass. With the boat in the water it can still be fixed. Close the seacock and take off the hose, now open the seacock and see if you get a good flow of water. If it a slow flow take a

                    long screwdriver 18in and run it up and down the opening Once you get a good flow close the seacock put the hose back on OPEN THE SEASEACOCK and you should be good to go. I have had to do this a few times. I have drilled out the holes at the intake to get more water but you also get more junk. When we anchor where there are lots of jellyfish and I run the genset I clean out the stainer everyday. Do not be afraid to open up the seacock with the hose off just make sure it is working well.

                    Comment


                      #11
                      Well Fellas it is fixed. Came down to the boat today determined to get it running. Took the raw water pump out, pulled all the hoses and ran water through everything. Put it all back together and fired it up and no overheating ! Temp stayed at 175 for an hour while I ran it. I guess an airlock was created somewhere . Glad to have it behind me. Thanks for the input guys.

                      Regards, Sea Shift

                      Comment

                      Working...
                      X