Announcement

Collapse
No announcement yet.

Generator cutting out-gctid363128

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Generator cutting out-gctid363128

    I have a 6KW Westerbeke in my 3288. It was running fine but now it starts up and runs for about 30 seconds and then just stops. Any idea's. Thanks in advance.

    #2
    Fuel pump, filter. Does it have a low oil shut down. I know on some of the Onans the pump would act up and if you tapped on it lightly it would come back on. On those you would have to change the pump. Sorry not real familiar with the Westerbrake.

    Comment


      #3
      Diesel I assume. If you can check and see if your fuel shut down solenoid is shutting down your engine. Have someone activate the preheat switch while you observe the solenoid. If this the engine dies when you release the preheat switch with the engine running it is likely there is a loose connection in the terminal box on the generator. If it runs after releasing the preheat switch it's likely that one of the emergence shutdown sensors is shutting down your fuel solenoid. There are three of these in series, oil pressure, engine temperature, and exhaust temperature. Since it is running for thirty seconds I would rule out all but exhaust temperature as it's the most likely to react this way. If that's the case it is possible you have cooling problems, either a failed water pump impeller or blockage of your water intake. You can check that quickly by observing water in your exhaust. If there is none this is probably your problem. Any one of these sensors could have failed, by disconnecting them one at a time you can isolate which sensor is bad. I don't think this is a fuel issue as once you starved the fuel pump it would not restart without priming and possibly bleeding

      the fuel system.

      Comment

      Working...
      X