Announcement

Collapse
No announcement yet.

Westerbeke 8 BTD Generator Started Overheating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Westerbeke 8 BTD Generator Started Overheating

    While on the hook last weekend (Florida), the generator ran fine overnight. Next day, it overheated. Checked strainer, oil ok, coolant okay. Good water flow at exhaust. Took temp readings when started from cold. After 5 minutes, temp gauge rising from 180. Thermostat housing 170, block 190, heat exchanger 78. Temp kept rising to 200 then shut down. How would I diagnose from here? Does this suggest a problem with heat exchanger (should it read ambient raw water temp)?
    1999 4087 with twin Cummins 270HP
    Custom Hardtop over Flybridge

    #2
    i would remove end caps on heat exchanger and verify that the cooling tubes are clean and not clogged up.
    Gibraltar, Mi.
    1986- 3870- Hino 175's
    1988 26' Shamrock/ Diesel
    14' Zodiac Bay Runner

    Comment


      #3
      How many hours on this genset?
      If near or over 1,000 have you inspected/cleaned/replaced teh exhaust elbow?

      What other symtoms does the genset have?
      smoke
      hard start
      vibration
      low coolant
      Northport NY

      Comment


      • Rk6johnson
        Rk6johnson commented
        Editing a comment
        Only 600 hours or less on Generator. A little white smoke, starts and runs well & smooth. No coolant use

      • smitty477
        smitty477 commented
        Editing a comment
        What is the condition of the fresh water (coolant) pump belt?
        Can you verify that coolant is circulating in that system?

        If the raw water system is flowing water well as you say the nect places to look are the coolant system and for exhaust blockages.
        Although it can always be the X-changer it hardly ever changes quickly unless you have raw water contamination in the coolant or low coolant indicating a leak.

      #4
      Have you checked the impeller?
      "Impasse". 2001 3988
      Cummins 330's
      Puget Sound

      "You don't want to be the richest guy in the nursing home..."

      Comment


        #5
        Have you checked your impeller? I had a similar situation this summer with my generator. It was fins missing from the impeller. Replaced it and back in business.
        16' lap straight with B&S inboard, my 1st commercial fishing adventure
        17' run about with original 80ph Volvo, fun with some exploration of the coast
        25' Chris Craft - lots of fun exploring further north on the BC coast
        32' wood commercial salmon troller - ice boat, hard work & fun
        41' wood commercial salmon troller - ice boat, hard work & fun
        38' Permaglass commercial salmon troller - freezer boat, harder work & fun
        1987 3870 with 175 Hinos - back to mostly fun again & exploration

        Comment


          #6
          All, Smitty had it right. I forgot to check the belt which isn’t too easy to get to. It was the problem! Thanks for input!
          1999 4087 with twin Cummins 270HP
          Custom Hardtop over Flybridge

          Comment


            #7
            Any experience changing this belt on a 4087? Not much room before bulk head! Just got the belt so looking for any input before wading in.
            1999 4087 with twin Cummins 270HP
            Custom Hardtop over Flybridge

            Comment


              #8
              With a Westerbeke 8.0 BTD Generator on a Bayliner 4087, WITH a sound shield, belt replacement is a BEAR! I went this morning planning to replace the belt then change oil. There is only about 2” clearance between the sound shield at the front of the generator and the bulkhead! There is less than and inch between plastic belt guard and the sound shield so taking the front panel of the shield off to replace drive belt is required! After removing several hose supports, I was able to get to the sound cover panel bolts with pliers to losses them. After removal with hoses moved, the top of the panel can be rotated away from the frame so the positioning pins clear. However, since the frame is aluminum and the panels are steel, the bottom of the panel was corroded to the aluminum track at the bottom. After an hour of wiggling prying, and hammering, I was able to break each side loose by hammering from the SIDE of the panel near the top.I was then able to maneuver the panel to Starboard and up to provide a little access. The belt guard is held on with 3 wing nuts, 2 on Starboard, 1 on port. Guard is slotted so after some gymnastics to loosen with pliers, I could slide the cover toward the bulkhead to reveal the pulleys. Next problem, the guard is trapped around the drive pulley due to the sound shield frame at the bottom! Since I could see all 3 pulleys, I proceeded to loosen the alternator bolts-3 1/2” bolts or nut on both ends of the adjustment support and the base end of the alternator to allow it to rotate. By moving a wire harness, I was able to gain maybe 3/8” travel. Next, I got my new belt, noticed there are 2 pulley locations on the drive, decided it looked like the most forward one was shiney so likely used — evaluating the alignment with the pump and alternator was very difficult so I plan to confirm cooroect drive pulley with Westerbeke. Tried to install new belt by putting it on drive at bottom and coolant pump then over the alternator pulley -not going to work. Not sure if belt may be too short or maybe I need to place the belt on alternator and pump pulleys then feed over drive?. After checking more, I’ll try again in a couple days. Needless to say, no oil change today! Sorry for long post but if someone else tries, this should help. PS Turns out I had the wrong belt. I’ll try soon with the correct one. The Dealer finde4 on Westerbeke site was very helpful.
              Last edited by Rk6johnson; 11-15-2020, 02:46 PM.
              1999 4087 with twin Cummins 270HP
              Custom Hardtop over Flybridge

              Comment


                #9
                New belt is on and generator doesn’t overheat! Tip, install belt from port side on the first groove of the drive pulley, then on the alternator pulley, and complete install on coolant pump pulley. Tighten from Starboard with brackets on alternator.
                1999 4087 with twin Cummins 270HP
                Custom Hardtop over Flybridge

                Comment


                  #10
                  I have a 1998 3988. I purchased this in May of 2021 following an 18 month negotiation. The boat has been inland in fresh water the majority of its life, it may have had a brief life in Florida in 1998. Being inland on smaller lakes in the Midwest, Lake of the Ozarks most of its life, and then Lewis and Clark Marina for the past 11 years, it has certainly not been maintained to blue water standards. It needs some TLC and my wife and I are looking forward to the task.

                  I have a Westerbeke 8 KW generator and it is running hot, in the 190 and higher range just based on the gauge reading. I have not check it with my IR thermometer but I will the next weekend. I also need to pull the noise shield so I can access it. I need to change all fluids, lube, and filters so I have a baseline for tracking maintenance. The boat came with almost no maintenance records.

                  It fires up very quick and runs well.

                  My question/concern is the exhaust. I can see that it runs through some large black canister. The canister is not fastened to the floor as I assume it should be, there is a makeshift wedge under it and there is a fairly significant kink in the hose leaving the canister. I suspicious that the kink my be the cause of the overheating, but Im not sure.

                  I was hoping I could get photos from other 3988 owners of their exhaust system and how that canister is mounted to the floor. I apologize for not including a photo in this post, I intended to and the day simply got a way from me. I will add a couple this weekend.

                  Today I fried the ice maker. User error we believe. Ouch!

                  Steven


                  1998 3988 Honu Kai
                  Twin Cummins 330's
                  Land Locked on the Missouri River

                  Comment

                  Working...
                  X