Announcement

Collapse
No announcement yet.

Port engine only starts when I parallel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stargazer
    commented on 's reply
    You’re probably right, I should just replace them. Thank you for the response

  • brad4550
    replied
    Remove cables from Start Batteries and use a "Load Tester" might even find that your multi meter will show a week battery......What are the Start Batteries ??. I would also check the date on them,I wouldn't think that they are original,if so need replacing anyway.

    Leave a comment:


  • vr5200
    replied
    Voltmeter is not a good indication of battery cranking capacity.

    I am assuming things were normal for a while and this problem recently developed.

    How old are the batteries?

    Are they sealed or can the cell caps be removed?

    The questionable battery needs to be properly load tested..............the other one for good measure as well.

    Any traditional wet cell battery in a boat application is on the downhill side of life after about 36-48 months.

    If any battery has been flat dead even once, that substantially shortens life.


    I don't know the details of the wiring of your boat, but it may also be possible that a cable is going bad.

    Do have a hand held meter and do you know how to use it for voltage testing?

    Leave a comment:


  • Stargazer
    started a topic Port engine only starts when I parallel

    Port engine only starts when I parallel

    I have a 2000 3988 I purchased recently. Last week the port engine failed to start unless I parallel the batteries. However, when I use a volt meter, all batteries look fine. Any tips?
Working...
X