Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Thermostat Sensor

Thermostat Sensor 25 Sep 2017 18:39 #1

  • Rfaich
  • Rfaich's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 22
  • Thank you received: 1
Hello to all Boaters. This 2017 season has been a pretty awesome experience for a new boater like myself. I have, however had a re-occuring issue that maybe some of you can help me more easily remedy. Earlier in the season, I took my 2016 VR5 up to Sebago lake in Maine. The long and the short of the story is that my 4.3L mercruiser went into guardian mode, beacause there was no temeperature reading being recorded, and my analog guage indicated that as well (it sat below 100). I was lucky enough to find a Mercury repairman locally who basically diaganosed the issue over the phone. I took it down to him and he resolved the issue in less than a hour. When I came to pick up the boat, he said it was just as he suspected. The sensor had been blocked up with sand and sediment, and was not sending any temperature measurement, thus shutting the boat down,even though it was not overheating.
Fast forward to last week. The boat had been running great since the July repair and I had taken it out several times since. I took the boat to a lake in Mashpee Ma, and I inadvertantly ran into shallow waters with a sandy, silted bottom. Soon thereafter, the boat went into guardian, and I was getting no temperature reading at my analog guage, which is usually between 150-180. Is this something that an average DIY guy can address, or is it something that my dealer needs to fix? I will tell you that the mechanic who did repair it the first go around, had it resolved in a very short time. Any help would be appreciated. I know this system is in place to safeguard an engine overheat/seizure, but now twice in a season, its become a nusance. The only thing that I do remember from the first repair is that a rubber gasket had to be sacrificed to get the sensor out and flushed. It was a 8 dollar part. Thanks for any help or suggestions.

Please Log in or Create an account to join the conversation.

Rick

2016 VR5

4.3L 220 MPI Mercruiser

Thermostat Sensor 25 Sep 2017 19:24 #2

  • TerryW
  • TerryW's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2308
  • Thank you received: 102
This is a simple mechanical issue. To be, maybe, a liitle curt it would be a good idea to be able to handle this level of work so that you dont get hopelessly stuck somewhere. You can search out and download the engine manual and search for advice on how to remove the sensor and flush the engine. It will build confidence to have a go. In the dock you can always call the maintenance guy if you get into trouble. The chap that used to work on my v8 was happy to let me watch and learn. I dont suppose that they are all so accommodating.
Good luck.
The following user(s) said Thank You: Rfaich

Please Log in or Create an account to join the conversation.

Terry (Retired Diving Instructor and Part Time IT Consultant)
1998 Bayliner 2452. 5.7l V8 - Edelbrock 1409 4bbl - Alpha1Gen2 - Solent UK.
MMSI 235061726

Thermostat Sensor 26 Sep 2017 15:15 #3

  • Rfaich
  • Rfaich's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 22
  • Thank you received: 1
I actually have trailered my boat this year, and routinely flush it anyway after each use. I agree, being in the "know" is definitely an advantage. Thanks for the advice and response.

Please Log in or Create an account to join the conversation.

Rick

2016 VR5

4.3L 220 MPI Mercruiser
  • Page:
  • 1
Moderators: Jim GandeeRuffryder
Time to create page: 0.077 seconds
Powered by Kunena Forum