Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 1999 2858 - 7.4 MPI - Stumbling / Electrical Harness Issue

1999 2858 - 7.4 MPI - Stumbling / Electrical Harness Issue 21 Aug 2017 14:09 #1

  • Capt. Bennett
  • Capt. Bennett's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 31
  • Thank you received: 1
Hello,

I had an issue earlier in the season in that when I was getting up on plane all of a sudden the engine stuttered and lost most of its power. When rpm was lowered it still was rough running and I suspected an electrical issue.

Upon starting to check the electrical connections the first one I put my hand on caused the engine to buck and then smooth right out. I turned off the engine, disconnected the connector and while it seemed pretty clean I cleaned with some contact cleaner than applied dielectric grease and put it back together. I got thru several boating days without issue but yesterday I experienced it again, and again when I hold the connector tight the issue seems to go away. I am thinking of just applying a couple of winding of electrical tape on it to keep a slight bit of pressure on the connection.

Questions:

1) What exactly is the connection shown in the attached picture? Port side of 1999 2858 7.4 MPI engine.

2) Has anyone else experienced this issue and what was the permanent fix? is this a standard type of connection that can be bought and replaced?


Thank-You,

Dion

This message has an attachment image.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: Jim GandeeRuffryder
Time to create page: 0.067 seconds
Powered by Kunena Forum