Welcome, Guest
Username: Password: Remember me

TOPIC: Loss of engine power; Mercruiser 5.0l MPI/Bravo 3

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 06 Sep 2017 19:29 #51

  • Chief Alen
  • Chief Alen's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Manalapan N.J
  • Posts: 10325
  • Thank you received: 1079
Next size up metric.

Could be the whole shebang there, i hesitated posting didn't want to add to the chaos.

Fuel smell in the exhaust, got to be 1 or more cylinders not firing.

Please Log in or Create an account to join the conversation.

Be good, be happy, for tomorrow is promised to no man !

1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

'86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 06 Sep 2017 20:25 #52

  • Nauti Mike
  • Nauti Mike's Avatar
  • Away
  • Platinum Member
  • Platinum Member
  • Perry Hall, MD
  • Posts: 2974
  • Thank you received: 360
I would install a new cap, going to a larger screw will cut into the metal of the distributor base and when you have to install a new cap in the future the standard screw would not work if the hole has been enlarged

Please Log in or Create an account to join the conversation.

1997 Maxum 2400 SCR 5.7LX Bravo II

Mike

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 06 Sep 2017 22:10 #53

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
Problem is the screw goes into the base, and I believe that's the hole that is stripped. So not sure how a new cap would help?

And it looks I can't just buy a new distributor base (which has the mounting holes) I have to buy a complete distributor assembly which is $900.
I sure hope a bigger screw works, or something else simple.

My son the auto mechanic believes that a standard Chevy distributor should work fine. On Ebay a distributor that looks the same to me is only $40! Could this work?? He also said I'd have to swap out the Cam sensor.

www.ebay.com/itm/New-Distributor-Chevy-S...AOSwjk9ZO34q&vxp=mtr

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III
Last Edit: by iceman11.

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 02:40 #54

  • Nauti Mike
  • Nauti Mike's Avatar
  • Away
  • Platinum Member
  • Platinum Member
  • Perry Hall, MD
  • Posts: 2974
  • Thank you received: 360
Ok I was thinking the screw was striped. You could fill the hole with some metal epoxy then drill a pilot hole that the screw can tap into.

Not sure if that auto distributor will work but if it has weights in it the advance curve will be different between auto and marine.
The following user(s) said Thank You: iceman11

Please Log in or Create an account to join the conversation.

1997 Maxum 2400 SCR 5.7LX Bravo II

Mike

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 03:16 #55

  • builderdude
  • builderdude's Avatar
  • Away
  • Platinum Member
  • Platinum Member
  • "THE FIX"
  • Posts: 4900
  • Thank you received: 809

Nauti Mike wrote: Ok I was thinking the screw was striped. You could fill the hole with some metal epoxy then drill a pilot hole that the screw can tap into.

Not sure if that auto distributor will work but if it has weights in it the advance curve will be different between auto and marine.

[/b]

+1

Please Log in or Create an account to join the conversation.

Dave
Edmonds, WA
"THE FIX"
'93 2556 5.7 Bravo II 2.0:1 18 1/4x19 P
.030 over-Vortec top end-part closed cooled
***The rebuild of my 2556***
www.baylinerownersclub.org/index.php/for...ansom-repair-my-2556

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 04:16 #56

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418
Merc's flat spyder cap had problems to start with.
sounds like a couple of holes weren't firing possibly ;) ,
Go with Napa Echlin line, better quality than OEM, ASE J1171 certified I think.
No weights,
all marine distributor must be ignition protected certified per you know.
www.napaechlin.com/media/2486784/NA10235DA-DYK_Dist_Assem.pdf
www.napaonline.com/en/p/ECHDA100_0416870569
The following user(s) said Thank You: iceman11

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 05:23 #57

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
Thanks guys. I will try the metal epoxy fill, that is worth a try.

The Mercury distributor has a Hall Effect Camshaft position sensor. Do you think I'll need to take it out of the old distributor and install in in the Napa Echlin one?

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 06:26 #58

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418
Mercruiser flat caps are notorious for failure... could possibly be the root of the cause.
try filling it with JB weld or re tap it bigger, but go get a new NAPA cap, even a GMC truck gold line cap.
yes, your old sensor can be swapped.

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 10:02 #59

  • Chief Alen
  • Chief Alen's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Manalapan N.J
  • Posts: 10325
  • Thank you received: 1079
I understand you don't want to crack it with a bigger screw.

Tap the hole one size bigger metric.

Please Log in or Create an account to join the conversation.

Be good, be happy, for tomorrow is promised to no man !

1994 2452, 5.0l, Alpha gen. 2 drive. Sold ! Sold ! Sold !

'86 / 19' Citation cuddy, Merc. 3.0L / 140 hp 86' , stringer drive. Sold ! Sold ! Sold !

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 16:42 #60

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
The mounting holes are on tabs off to each side of the distributor base. On one side, part of the plastic cracked off today when I took out the screw so now it's open. I will try to epoxy that back on and drill a hole, but I'm not very optimistic.

Meanwhile I'm heading to the local Napa to see if they can get the Distributor.

I'm not 100% convinced this was the source of the power loss. I think we probably stripped the hole last Saturday, and the power loss started on July 1. I remember taking the cap off when I got back that day to inspect it, and I don't remember having a problem re-mounting it, and it didn't seem loose at first on Saturday. Nonetheless it still has to be fixed.

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 07 Sep 2017 19:04 #61

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418
I've seen more than a few times those defective Mercs flat cap to cause similar symptoms as you are experiencing in the past...
The following user(s) said Thank You: iceman11

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 09 Sep 2017 00:21 #62

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
Fuel injectors came back today. According to the mechanic 7 of them were operating at 71%, the 8th was 64%. I will reinstall them and try and fix the distributor this weekend, and then I guess we'll re-launch and see how it runs.

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 10 Sep 2017 00:16 #63

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418
Good news!
Smart to have them cleaned professionally... thought I suggested doing so, but I'm not reading it on this thread.
Perhaps this explains fuel pressure being a bit high at WOT.

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 18 Sep 2017 05:29 #64

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
Checking in with status. Re-installed the clean fuel injectors, replaced the damaged distributor with the NAPA Echlin, and launched for an on-the-water test. Still no joy .... engine tops out at 2800 RPM.

So we're back to checking the cylinders after having ruled out a long list of potential causes. I towed the boat back to the marine mechanics shop on Friday and expect I'll hear back from him this week. His plan is to do the leak down test.

Here's another unconventional thought, assuming the leak down test doesn't reveal a problem. The Mercruiser MPI engine has "Guardian Mode" where the computer limits the engine RPM if it thinks there is a fault that could cause engine damage. Normally (maybe always?) this happens when the engine alarm is heard. Is it possible that the engine is being put in Guardian mode in error, with no fault being sensed or by some condition that doesn't generate an alarm or fault code? Or that the computer itself has a fault that is forcing Guardian mode. From all I've read I believe that this SHOULDN'T happen, but the question is, is it POSSIBLE? If so, how would we be able to diagnose that?

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 29 Sep 2017 16:32 #65

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
Latest update: the marine mechanic did the leak down test and the #1 cylinder failed badly (40%). Other cylinders leaked but not as much. The leaks turned out to be from the valves: 4 exhaust valves and 1 intake. He believes the head is warped, which is possible since the engine overheated 2 years ago. He saw black carbon buildup on some of the valve seats. He machined the head, valves and valve seats and put everything back together.

I launched yesterday hoping for the best, but the bottom line is the loss of power is still there, pretty much the same; 2800 RPM max. When I throttle up past that we smell gas in the exhaust.

Needless to say I'm pretty discouraged. That was a $2500 job. Seems like it was still needed but now we're back to square 1 on the power loss problem. I asked him if the engine was in Guardian mode for some reason and he said no, it would report that to the scanner.

Next step is he's going to get a Mercury factory rep to take a boat ride with us and do diagnostics with his computer, which I assume is more sophisticated than a regular scanner.

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 29 Sep 2017 17:45 #66

  • Nauti Mike
  • Nauti Mike's Avatar
  • Away
  • Platinum Member
  • Platinum Member
  • Perry Hall, MD
  • Posts: 2974
  • Thank you received: 360

iceman11 wrote: Latest update: the marine mechanic did the leak down test and the #1 cylinder failed badly (40%). Other cylinders leaked but not as much. The leaks turned out to be from the valves: 4 exhaust valves and 1 intake. He believes the head is warped, which is possible since the engine overheated 2 years ago. He saw black carbon buildup on some of the valve seats. He machined the head, valves and valve seats and put everything back together.

I launched yesterday hoping for the best, but the bottom line is the loss of power is still there, pretty much the same; 2800 RPM max. When I throttle up past that we smell gas in the exhaust.

Needless to say I'm pretty discouraged. That was a $2500 job. Seems like it was still needed but now we're back to square 1 on the power loss problem. I asked him if the engine was in Guardian mode for some reason and he said no, it would report that to the scanner.

Next step is he's going to get a Mercury factory rep to take a boat ride with us and do diagnostics with his computer, which I assume is more sophisticated than a regular scanner.



Not surprised about the head issue, was it both or just one head?

Sucks this did not resolve the issue. Hopefully the mecr rep can figure it out.

Please Log in or Create an account to join the conversation.

1997 Maxum 2400 SCR 5.7LX Bravo II

Mike

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 30 Sep 2017 17:35 #67

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
Mike, both heads were warped. The worst valve seat was off by 0.008" , which is alot acc to the mechanic. I'm surprised we didn't see at least some improvement on the water.

We've checked so many things. I can't fathom what could be wrong at this point. Not sure how the Merc rep is going to help.

I'm starting to wonder, could something be wrong with the stern drive? The props are original. Could the drivetrain be screwed up somehow? Not sure it makes sense.... why would that limit the engine RPM... seems to me the engine RPM would still go higher but I just wouldn't get the power to the prop.

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 30 Sep 2017 21:55 #68

  • Nauti Mike
  • Nauti Mike's Avatar
  • Away
  • Platinum Member
  • Platinum Member
  • Perry Hall, MD
  • Posts: 2974
  • Thank you received: 360
For the props to limit the rpm by this much the damade would be obvious. Diagnosing this over the net is hard for me to advise what is the next step. The valve job should address the vacuum being low.

Please Log in or Create an account to join the conversation.

1997 Maxum 2400 SCR 5.7LX Bravo II

Mike

Loss of engine power; Mercruiser 5.0l MPI/Bravo 3 30 Sep 2017 22:11 #69

  • iceman11
  • iceman11's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 54
  • Thank you received: 0
I know Mike, I appreciate all of your efforts to help. This one isn't easy for sure - it's eluded 2 experienced mechanics here locally so far.

I agree about the vacuum, so I'll be checking that this week as soon as I can get my hands on a gauge.

Please Log in or Create an account to join the conversation.

2006 Maxum 2600SE with Merc 5.0L MPI/Bravo III
Moderators: Jim GandeeRuffryder
Time to create page: 0.123 seconds
Powered by Kunena Forum