Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: New boat horn wont work.

New boat horn wont work. 28 Jul 2017 16:37 #1

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
So I bought the Marinco Electric Dual Horn new for my 87 Wellcraft Antigua. The same old one would only click once when I pressed the horn button. I figured it was old and worn out. Put the new one in and same... darn... thing. First I put the old one to a spare battery, it just sounds like a bad fart so yes it needed changed. I pulled the switch panel and made contact with the two wire ends that went into the switch. This made the same click so its not the switch. It did however spark a little and smoke. I checked the connections at the horns wiring harness and they were all good. I think I have a short and now I need to run a check on each wire and connection on this? I found a rust area in the ceiling carpet just under the horn mounting bracket on the top of the deck. Can any one give me any pointers. Do I need to pull the ceiling carpet then spray adhesive back in place?

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD
Last Edit: by dockofthebay.

New boat horn wont work. 29 Jul 2017 03:46 #2

  • SKUA 28 Contessa
  • SKUA 28 Contessa's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • In over my head... for sure.
  • Posts: 626
  • Thank you received: 74
Check your horn for an odd looking screw that appears to do nothing. Many better horns have a "tuning" screw, that will go from a fart or click and smoke, to a screech or honk depending on how far in or out you turn the screw
The following user(s) said Thank You: dockofthebay

Please Log in or Create an account to join the conversation.

1986 Bayliner Contessa 2850
On the hard undergoing, a full on refit and repower, with Chevrolet 454
Making real progress now
baylinerownersclub.org/index.php/forum/g...to-leak?limitstart=0

New boat horn wont work. 29 Jul 2017 11:59 #3

  • diveguy
  • diveguy's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • St.Margarets Bay, NS
  • Posts: 1368
  • Thank you received: 166
Check your connections at the fuse block. I bought the same horn this year and had a similar problem. I replaced the original glass fuse block as the fuse holder connections were poor. I replaced with a Blue Sea automotive style fuse block and now everything is working great. Those horns draw about 8amps so you need a good connection.
The following user(s) said Thank You: dockofthebay

Please Log in or Create an account to join the conversation.

"Martini's Law"
1986 Bayliner 3270, 110 Hino's
Nova Scotia, Canada

New boat horn wont work. 30 Jul 2017 20:48 #4

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
Diveguy, I found the fuse panel for my boat. It is original and yes has the old glass tube fuse holder. I am going to hate to have to do that cuz I do not get along well with electronic wiring on something that big. On the sounds your horn made, is it where you can hear it start to blow but its so weak that it sounds more like a click than anything else?

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD
Last Edit: by dockofthebay.

New boat horn wont work. 30 Jul 2017 23:40 #5

  • diveguy
  • diveguy's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • St.Margarets Bay, NS
  • Posts: 1368
  • Thank you received: 166

dockofthebay wrote: Diveguy, I found the fuse panel for my boat. It is original and yes has the old glass tube fuse holder. I am going to hate to have to do that cuz I do not get along well with electronic wiring on something that big. On the sounds your horn made, is it where you can hear it start to blow but its so weak that it sounds more like a click than anything else?


Sometimes just turning the fuse in the holder may help the connection. I assume the fuse block you're referring to is on the bridge? They would be more susceptible to corrosion then in the cabin.
Most times I would only get a click when I was having issue.
The following user(s) said Thank You: dockofthebay

Please Log in or Create an account to join the conversation.

"Martini's Law"
1986 Bayliner 3270, 110 Hino's
Nova Scotia, Canada

New boat horn wont work. 31 Jul 2017 18:35 #6

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
Dive guy, Thank you. Problem solved... Sort of. I redid all connections getting much better uncorroded contact. It worked!!! But then I discovered that the battery switch this time was only on battery 2. Before I had it on battery All. Shouldn't battery All run everything off of both batteries?

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD

New boat horn wont work. 31 Jul 2017 20:24 #7

  • diveguy
  • diveguy's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • St.Margarets Bay, NS
  • Posts: 1368
  • Thank you received: 166
Very good! You need to find out which is your house battery and which is the start battery. Running the boat with the switch on "all" is ok as the alternator would be charging both at the same time. When your at anchor, you only want to use your house battery for risk of depleting the start battery. I few pictures of your battery's and switch may be helpful for others more knowledgeable to chime in.

Please Log in or Create an account to join the conversation.

"Martini's Law"
1986 Bayliner 3270, 110 Hino's
Nova Scotia, Canada

New boat horn wont work. Now it does!!! 31 Jul 2017 22:10 #8

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
Ok so the batteries have been charging for about 3 hours. I wont start the motor cuz I'm not dragging the garden hose 150 feet to the boat but I turned the motor power on and both banks show gauges working and starter kick on. The refrigerator, water pressure and lights in the cabin all work on both battery sets. The stereo, nav system and the horn only work on batt 1 set. Oh and BTW, both horns work now. Maybe it was charging the batteries or replacing all the connections for the horn. I've also included the photos of the fuse block which is frightening and what the engine compartment looks like.

This message has attachments images.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD

New boat horn wont work. Now it does!!! 01 Aug 2017 00:44 #9

  • diveguy
  • diveguy's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • St.Margarets Bay, NS
  • Posts: 1368
  • Thank you received: 166
Hard to tell what's going on from the pics. The two red(positive) that are tie wrapped from the switch may be the start battery. You should also make sure you have clean connection at the battery terminals themselves. You may want to have a marine electrician come have have look to sort things out. Money well spent for an hour or two to sort things out.

Please Log in or Create an account to join the conversation.

"Martini's Law"
1986 Bayliner 3270, 110 Hino's
Nova Scotia, Canada

New boat horn wont work. Now it does!!! 01 Aug 2017 01:33 #10

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
I might be looking at $120ish but it will be worth it when I get the opportunity.

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD

New boat horn wont work. 01 Aug 2017 11:36 #11

  • diveguy
  • diveguy's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • St.Margarets Bay, NS
  • Posts: 1368
  • Thank you received: 166
This is the fuse block I installed and now I don't have issues.

This message has an attachment image.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

"Martini's Law"
1986 Bayliner 3270, 110 Hino's
Nova Scotia, Canada

New boat horn wont work. 02 Aug 2017 20:54 #12

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
Nice man. How much was that?

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD

New boat horn wont work. 02 Aug 2017 21:36 #13

  • diveguy
  • diveguy's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • St.Margarets Bay, NS
  • Posts: 1368
  • Thank you received: 166
$65 CAD.

Please Log in or Create an account to join the conversation.

"Martini's Law"
1986 Bayliner 3270, 110 Hino's
Nova Scotia, Canada

New boat horn wont work. 04 Aug 2017 17:59 #14

  • dockofthebay
  • dockofthebay's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 333
  • Thank you received: 24
Very good price. Thank you so much.

Please Log in or Create an account to join the conversation.

1994 Bayliner Capri 1850, 3 liter Mercruiser, 9.9 Johnson kicker.
1987 Wellcraft Antigua 265, Mercruiser 383 Stroker V8.
Pulls with Ext. Cab 2006 GMC Sierra 2500 HD
  • Page:
  • 1
Moderators: JeffwAlaskanmutt
Time to create page: 0.105 seconds
Powered by Kunena Forum