Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Guages and Instruments not working on Bayliner 185 (2007)

Guages and Instruments not working on Bayliner 185 (2007) 02 Jun 2015 18:50 #1

  • Skyloran
  • Skyloran's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
  • Thank you received: 0
Hi, over time some of my gauges have stopped working. The speed guage sometimes sticks, the rpm does not work and the fuel guage sticks or doesn't function (I don't trust it). Also the blower switch no longer turns on the blower (the blower itself works). I carefully maintain this boat that I purchased new. I am wondering if others have had similar experiences with guages in their Bayliner 185s. It seems strange that so many of the guages would stop working properly. Is this common with the Bayliner 185? Any lessons learned?
Thank you

Please Log in or Create an account to join the conversation.

Guages and Instruments not working on Bayliner 185 (2007) 02 Jun 2015 19:28 #2

  • MonteVista
  • MonteVista's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 1169
  • Thank you received: 179
A common point to all these devices is their pwr/gnd source. I believe they receive both power and gnd from the fusepanel. A corroded/loose connection may the the root cause. Check the wiring.

Good luck!
The following user(s) said Thank You: Skyloran

Please Log in or Create an account to join the conversation.

Retired, computer expert / executive
Bayliner 285 Cruiser / Mercruiser QSD 4.2L 320 HP Diesel
Live in the Bay Area, CA, USA, boat in Turkey
D-Marin @ Turgutreis in Bodrum/Turkey
This email address is being protected from spambots. You need JavaScript enabled to view it.
This email address is being protected from spambots. You need JavaScript enabled to view it.

Guages and Instruments not working on Bayliner 185 (2007) 02 Jun 2015 19:50 #3

  • pat8839
  • pat8839's Avatar
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 319
  • Thank you received: 3
I have a 2006 195BR that I have had to replace almost all the switches on now. I do my best to take good care of her, but she does live outside under 2 covers. Before the switches went out mechanically some anticorrosion spray coating would help when I had connection issues. I have not had any issues from the power block itself though.

Good luck! Keep us posted
The following user(s) said Thank You: Skyloran

Please Log in or Create an account to join the conversation.

Guages and Instruments not working on Bayliner 185 (2007) 02 Jun 2015 20:36 #4

  • Greg Tomamichel
  • Greg Tomamichel's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 763
  • Thank you received: 98

MonteVista wrote: A common point to all these devices is their pwr/gnd source. I believe they receive both power and gnd from the fusepanel. A corroded/loose connection may the the root cause. Check the wiring.

Good luck!


+1 It seems highly unlikely that all these things would fail independently, and agree that a common issue on either +ve or -be side makes sense.

With regard the fuel gauge, I think they all stick. I regard our as accurate to +/- 1/4 of a tank.
The following user(s) said Thank You: Skyloran

Please Log in or Create an account to join the conversation.

2007 Bayliner 175 3.0l Mercruiser
Lake use for water sports
Victoria, Australia

Guages and Instruments not working on Bayliner 185 (2007) 21 Jun 2015 06:46 #5

  • Skyloran
  • Skyloran's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
  • Thank you received: 0
Thanks for the replies. I will check all the potential corrosion points and let everyone know what I find. Sorry I have been so long in replying but have been busy.

Please Log in or Create an account to join the conversation.

Guages and Instruments not working on Bayliner 185 (2007) 21 Jun 2015 07:21 #6

  • Greg Tomamichel
  • Greg Tomamichel's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 763
  • Thank you received: 98
Good luck, and hopefully it hasn't interupted your season.

Please Log in or Create an account to join the conversation.

2007 Bayliner 175 3.0l Mercruiser
Lake use for water sports
Victoria, Australia

Guages and Instruments not working on Bayliner 185 (2007) 30 Jul 2015 15:59 #7

  • nicker22
  • nicker22's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 156
  • Thank you received: 13
Did you ever get your gauge issue's fixed ? I have a similar issue on my speedo.

Please Log in or Create an account to join the conversation.

Bayliner 185 BR
3.0 Merc Cruiser
Last Edit: by nicker22. Reason: spelling

Guages and Instruments not working on Bayliner 185 (2007) 30 Jul 2015 16:15 #8

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418

nicker22 wrote: Did you ever get your gauge issue's fixed ? I have a similar issue on my speedo.


Check your pitot tube

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Guages and Instruments not working on Bayliner 185 (2007) 30 Jul 2015 18:50 #9

  • nicker22
  • nicker22's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 156
  • Thank you received: 13

Ruffryder wrote:

nicker22 wrote: Did you ever get your gauge issue's fixed ? I have a similar issue on my speedo.


Check your pitot tube


where does that end ? Or do I take it off the speedo and blow it out with an air line?

Please Log in or Create an account to join the conversation.

Bayliner 185 BR
3.0 Merc Cruiser

Guages and Instruments not working on Bayliner 185 (2007) 30 Jul 2015 18:56 #10

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418

nicker22 wrote:

Ruffryder wrote:

nicker22 wrote: Did you ever get your gauge issue's fixed ? I have a similar issue on my speedo.


Check your pitot tube


where does that end ? Or do I take it off the speedo and blow it out with an air line?

Should fill out your SIG.
Do you have an Alpha? Raise the drive, you'll see it just below the shift lever.

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Guages and Instruments not working on Bayliner 185 (2007) 30 Jul 2015 19:04 #11

  • HUSKEY BAY
  • HUSKEY BAY's Avatar
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 385
  • Thank you received: 85
have different boats but same problem.... little corrosion builds up and experience intermittent gauge performance Happens on both my salt water and fresh water boat. I just clean them up ad coat them. God luck, be safe.

Please Log in or Create an account to join the conversation.

Guages and Instruments not working on Bayliner 185 (2007) 31 Jul 2015 12:30 #12

  • nicker22
  • nicker22's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 156
  • Thank you received: 13

Ruffryder wrote:

nicker22 wrote:

Ruffryder wrote:

nicker22 wrote: Did you ever get your gauge issue's fixed ? I have a similar issue on my speedo.


Check your pitot tube


where does that end ? Or do I take it off the speedo and blow it out with an air line?

Should fill out your SIG.
Do you have an Alpha? Raise the drive, you'll see it just below the shift lever.



Thanks Ruffryder, I checked the tub and blew some air in there and sure enough the speedo needle moved up. I will test it again when I am out on the water this weekend.

Please Log in or Create an account to join the conversation.

Bayliner 185 BR
3.0 Merc Cruiser

Guages and Instruments not working on Bayliner 185 (2007) 31 Jul 2015 15:37 #13

  • Ruffryder
  • Ruffryder's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 7639
  • Thank you received: 1418

nicker22 wrote:

Ruffryder wrote:

nicker22 wrote:

Ruffryder wrote:

nicker22 wrote: Did you ever get your gauge issue's fixed ? I have a similar issue on my speedo.


Check your pitot tube


where does that end ? Or do I take it off the speedo and blow it out with an air line?

Should fill out your SIG.
Do you have an Alpha? Raise the drive, you'll see it just below the shift lever.



Thanks Ruffryder, I checked the tub and blew some air in there and sure enough the speedo needle moved up. I will test it again when I am out on the water this weekend.


Nice SIG :cheer:

Please Log in or Create an account to join the conversation.

Joon, Kathy, Jaden & Tristan
93 3058
92 2855
91 Fourwinns 205
Longbranch WA
Life is Good

Guages and Instruments not working on Bayliner 185 (2007) 10 Apr 2017 02:20 #14

  • Skyloran
  • Skyloran's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
  • Thank you received: 0
Again, thanks to all that replied regarding my guage problem. I did not get them sorted out this last season but I am getting a head start this season. I wasn't too worried about the rpm since I knew the prop would not allow me to over rev and I didn't care all that much about the speed. I do wish I had an accurate fuel guage however but thats not in the cards I guess.
I just wanted all to realize that I will look and use your valuable suggestions.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: Download_Completehiggins_jr
Time to create page: 0.112 seconds
Powered by Kunena Forum